Those of you holding off for an official Dev-Team jailbreak solution to the recently released 3.1.2 firmware pushed out by Apple have something exciting to come home to. PwnageTool 3.1.4 for Mac OS X has officially been released bringing with it freedom for most. I say most because 3G iPod Touches aren’t supported. It’s also important to note that in order to keep your phone unlocked, you’ll need to upgrade to 3.1.2 via custom built ISPW’s via PwnageTool as fresh 3.1.2 devices have an updated baseband that at this point isn’t able to be downgraded. Finally, the iPod Touch 2nd Gen must already be jailbroken in order to stay jailbroken on 3.1.2 and using PwnageTool. The Dev-Team does mention however if enough demand is seen, they’ll make the process easier for 2nd Gen touch owners as well. Why they didn’t from the get go is beyond me. Hey, I’m not a software developer/code magician so I’ll respect their decisions.

Per Dev-Team:

This release allows your baseband to remain unlocked at 3.1.2, but it does not unlock a new baseband put there by restoring to official 3.1.x. It is super important that people who need the unlock to understand they can keep it only by starting at 3.0 (or earlier) and updating solely to custom IPSWs that don’t update the baseband.

If you’re looking for something a bit more Windows based, revert back to Blackra1n for now.
Geeky-Gadgets > Dev-Team